summaryrefslogtreecommitdiff
path: root/radsecproxy/Makefile.am
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2014-02-05 11:10:02 +0100
committerLinus Nordberg <linus@nordberg.se>2014-02-05 11:10:02 +0100
commit3d954bfd2f658ac05a0f20a1241738ed3e3fdd28 (patch)
treed95b364fbab298c9b94c9c729afc98904c7c5bb0 /radsecproxy/Makefile.am
parent67bdfa83f1879312fef0fbac769f6fb45df12d1a (diff)
Move lib to the root.
Diffstat (limited to 'radsecproxy/Makefile.am')
-rw-r--r--radsecproxy/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/radsecproxy/Makefile.am b/radsecproxy/Makefile.am
new file mode 100644
index 0000000..dc5ffc4
--- /dev/null
+++ b/radsecproxy/Makefile.am
@@ -0,0 +1,23 @@
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4
+
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)
+AM_CFLAGS = -Wall -Werror -g
+
+noinst_LTLIBRARIES = libradsec-radsecproxy.la
+
+libradsec_radsecproxy_la_SOURCES = \
+ debug.c debug.h \
+ gconfig.h \
+ hash.c hash.h \
+ hostport_types.h \
+ list.c list.h \
+ radmsg.h \
+ radsecproxy.h \
+ tlv11.h \
+ util.c util.h
+
+if RS_ENABLE_TLS
+libradsec_radsecproxy_la_SOURCES += \
+ tlscommon.c tlscommon.h
+endif