summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordu.net>2016-03-09 12:12:03 +0100
committerLinus Nordberg <linus@nordu.net>2016-03-09 12:12:03 +0100
commit30670f3de0976ad15f0479b38a60a08c3fced0f6 (patch)
tree3845bff0f1d171762e0f9f43528482d30a8427dc /Makefile.am
parent4c9e9cf5ef9eeb2bb79695a235f2dc7919789bcd (diff)
Fix the html target.
List the three .html files. Add targets for building .html from .1 and .5.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 0cb8516..1d10e30 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,7 +12,6 @@ endif
SUBDIRS = tests
-
sbin_PROGRAMS = radsecproxy
bin_PROGRAMS = radsecproxy-conf $(fticks_programs)
noinst_LIBRARIES = librsp.a
@@ -67,10 +66,12 @@ DISTCHECK_CONFIGURE_FLAGS = --enable-fticks
radsecproxy.conf.5: $(srcdir)/radsecproxy.conf.5.xml
docbook2x-man $<
-# Build HTML version of radsecproxy.conf.5. NOTE: Only tested with
-# 'openjade' package installed on Ubuntu 9.10.
-html: $(srcdir)/radsecproxy.conf.5.xml
- -openjade -E2000 -t sgml-raw -d /usr/share/sgml/docbook/stylesheet/dsssl/modular/html/docbook.dsl -o radsecproxy.conf.html $<
+html: radsecproxy.html radsecproxy-hash.html radsecproxy.conf.html
+
+%.html: %.1
+ groff -mandoc -Thtml $< >$@
+%.html: %.5
+ groff -mandoc -Thtml $< >$@
clean-local:
-rm $(GENMANPAGES)