From a13cddc1331aa1f5e7dca7d1b44482951d2757bf Mon Sep 17 00:00:00 2001
From: Luke Howard <lukeh@padl.com>
Date: Sun, 13 Nov 2011 17:16:14 +1100
Subject: port to new RADIUS client library

---
 lib/configure.ac | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

(limited to 'lib/configure.ac')

diff --git a/lib/configure.ac b/lib/configure.ac
index 9a618f8..086a4fe 100644
--- a/lib/configure.ac
+++ b/lib/configure.ac
@@ -17,8 +17,6 @@ AC_CHECK_LIB([confuse], [cfg_init],,
     AC_MSG_ERROR([required library libconfuse not found]))
 AC_CHECK_LIB([event_core], [event_get_version],,
     AC_MSG_ERROR([required library libevent_core not found]))
-AC_CHECK_LIB([freeradius-radius], [rad_alloc],,
-    AC_MSG_ERROR([required library libfreeradius-radius not found]))
 
 # Enable-knobs.
 AH_TEMPLATE([RS_ENABLE_TLS], [TLS (RadSec) enabled])
@@ -43,6 +41,7 @@ AC_TYPE_UINT8_T
 AC_CHECK_FUNCS([memset socket strdup strerror strrchr])
 
 AC_CONFIG_FILES([Makefile
+		 radius/Makefile
 		 include/Makefile
                  examples/Makefile
                  tests/Makefile])
-- 
cgit v1.1


From ac17a556bd50969c8157d50761449b702afa4af8 Mon Sep 17 00:00:00 2001
From: Luke Howard <lukeh@padl.com>
Date: Mon, 14 Nov 2011 16:59:55 +1100
Subject: port new RADIUS library to Windows

Conflicts:

	lib/configure.ac
	lib/include/radsec/radsec.h
	lib/radius/client.h
---
 lib/configure.ac | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

(limited to 'lib/configure.ac')

diff --git a/lib/configure.ac b/lib/configure.ac
index 086a4fe..9b1d304 100644
--- a/lib/configure.ac
+++ b/lib/configure.ac
@@ -30,7 +30,8 @@ AM_CONDITIONAL([RS_ENABLE_TLS], [test "${enable_tls+set}" = set])
 
 # Checks for header files.
 AC_CHECK_HEADERS(
-    [netdb.h netinet/in.h stdint.h stdlib.h string.h sys/socket.h unistd.h])
+    [sys/time.h time.h netdb.h netinet/in.h stdint.h stdlib.h strings.h string.h \
+     sys/socket.h unistd.h syslog.h sys/select.h fcntl.h arpa/inet.h])
 
 # Checks for typedefs, structures, and compiler characteristics.
 AC_TYPE_SIZE_T
-- 
cgit v1.1