summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am27
1 files changed, 18 insertions, 9 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 237294a..e202218 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -16,6 +16,9 @@ ACLOCAL_AMFLAGS = -I m4
# the library interface is _extended_. Set AGE to 0 when the library
# interface is _changed_.
+VER_CUR = 1
+VER_REV = 0
+VER_AGE = 0
SUBDIRS = radius radsecproxy include . examples
DIST_SUBDIRS = $(SUBDIRS) tests
@@ -29,11 +32,13 @@ libradsec_la_SOURCES = \
avp.c \
compat.c \
conf.c \
+ confutil.c \
conn.c \
debug.c \
err.c \
event.c \
- packet.c \
+ listener.c \
+ message.c \
peer.c \
radsec.c \
request.c \
@@ -43,9 +48,9 @@ libradsec_la_SOURCES = \
util.c
if RS_ENABLE_TLS
-libradsec_la_SOURCES += tls.c
+ libradsec_la_SOURCES += tls.c
else
-libradsec_la_SOURCES += md5.c
+ libradsec_la_SOURCES += md5.c
endif
libradsec_la_SOURCES += \
@@ -55,7 +60,6 @@ libradsec_la_SOURCES += \
err.h \
event.h \
md5.h \
- packet.h \
peer.h \
radsec.h \
tcp.h \
@@ -63,9 +67,14 @@ libradsec_la_SOURCES += \
udp.h \
util.h
-EXTRA_DIST = HACKING LICENSE libradsec.spec radsec.sym
-AM_DISTCHECK_CONFIGURE_FLAGS = --enable-tls --enable-tls-psk
+EXTRA_DIST = HACKING LICENSE radsec.sym
+EXTRA_libradsec_la_DEPENDENCIES = radsec.sym
-libradsec_la_LIBADD = radsecproxy/libradsec-radsecproxy.la radius/libradsec-radius.la
-libradsec_la_LDFLAGS = -version-info 0:0:0 -export-symbols $(srcdir)/radsec.sym
-libradsec_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H -Werror # -DDEBUG -DDEBUG_LEVENT
+libradsec_la_CFLAGS = \
+ $(AM_CFLAGS) -DHAVE_CONFIG_H #-DDEBUG -DDEBUG_LEVENT
+libradsec_la_LDFLAGS = \
+ -version-info $(VER_CUR):$(VER_REV):$(VER_AGE) \
+ -export-symbols $(srcdir)/radsec.sym
+libradsec_la_LIBADD = \
+ radsecproxy/libradsec-radsecproxy.la \
+ radius/libradsec-radius.la