summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac31
1 files changed, 29 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 11bad1d..570c5dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,8 +1,13 @@
+<<<<<<< HEAD
+AC_INIT(radsecproxy, 1.5-dev, radsecproxy@uninett.no)
+=======
AC_INIT(radsecproxy, 1.4.3, radsecproxy@uninett.no)
+>>>>>>> master
AC_CANONICAL_TARGET
AM_INIT_AUTOMAKE
AC_PROG_CC
AM_PROG_CC_C_O
+AC_PROG_RANLIB
udp=yes
AC_ARG_ENABLE(udp,
[ --enable-udp whether to enable UDP transport: yes/no; default yes ],
@@ -46,7 +51,26 @@ AC_ARG_ENABLE(dtls,
exit -1
fi
])
-
+
+AC_ARG_ENABLE(fticks,
+AC_HELP_STRING([--enable-fticks],[build with F-Ticks support [default=no]]),
+[case $enableval in
+yes|no) ;;
+*) AC_MSG_ERROR([bad value $enableval for --enable-fticks, need yes or no]) ;;
+esac],
+[enable_fticks=no])
+
+if test "$enable_fticks" = "yes"; then
+AC_CHECK_LIB([nettle], [nettle_sha256_init],,
+ [AC_MSG_WARN([required library nettle not found, fticks support disabled])
+ enable_fticks=no])
+fi
+
+if test "$enable_fticks" = "yes"; then
+AC_DEFINE([WANT_FTICKS], [1])
+fi
+AM_CONDITIONAL(WANT_FTICKS, test "$enable_fticks" = "yes")
+
dnl Check if we're on Solaris and set CFLAGS accordingly
AC_CANONICAL_SYSTEM
case "${target_os}" in
@@ -88,4 +112,7 @@ AM_CONDITIONAL(HAVE_DOCBOOK2X_MAN, test "$DOCBOOK2X_MAN" = "yes")
AC_SUBST(TARGET_CFLAGS)
AC_SUBST(TARGET_LDFLAGS)
AX_CHECK_SSL
-AC_OUTPUT(Makefile)
+AC_OUTPUT([
+ Makefile
+ tests/Makefile
+])