summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 3 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index e4a6ef9..b8f75c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,5 @@
AUTOMAKE_OPTIONS = foreign
-if WANT_FTICKS
-fticks_sources = fticks.c fticks.h fticks_hashmac.c fticks_hashmac.h
-fticks_programs = radsecproxy-hash
-radsecproxy_hash_LDADD = fticks_hashmac.o hash.o list.o
-endif
-
if HAVE_DOCBOOK2X_MAN
GENMANPAGES = radsecproxy.conf.5
endif
@@ -13,15 +7,15 @@ endif
SUBDIRS = tests
sbin_PROGRAMS = radsecproxy
-bin_PROGRAMS = radsecproxy-conf $(fticks_programs)
+bin_PROGRAMS = radsecproxy-conf radsecproxy-hash
noinst_LIBRARIES = librsp.a
radsecproxy_SOURCES = main.c
librsp_a_SOURCES = \
- $(fticks_sources) \
debug.c debug.h \
dtls.c dtls.h \
+ fticks.c fticks.h fticks_hashmac.c fticks_hashmac.h \
gconfig.c gconfig.h \
hash.c hash.h \
hostport.c hostport.h \
@@ -48,8 +42,8 @@ AM_CFLAGS = \
radsecproxy_LDFLAGS = @SSL_LDFLAGS@ @TARGET_LDFLAGS@
radsecproxy_LDADD = librsp.a @SSL_LIBS@
-
radsecproxy_conf_LDFLAGS = @TARGET_LDFLAGS@
+radsecproxy_hash_LDADD = fticks_hashmac.o hash.o list.o
dist_man_MANS = radsecproxy.1 radsecproxy-hash.1 $(GENMANPAGES)
@@ -60,8 +54,6 @@ EXTRA_DIST = \
radsecproxy.conf.5.xml radsecproxy.conf-example \
tools/README tools/naptr-eduroam.sh tools/radsec-dynsrv.sh
-DISTCHECK_CONFIGURE_FLAGS = --enable-fticks
-
####################
radsecproxy.conf.5: $(srcdir)/radsecproxy.conf.5.xml
docbook2x-man $<