summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am79
1 files changed, 40 insertions, 39 deletions
diff --git a/Makefile.am b/Makefile.am
index cd40c2a..2067c5d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,51 +1,52 @@
AUTOMAKE_OPTIONS = foreign
+SUBDIRS = tests
+
sbin_PROGRAMS = radsecproxy
-bin_PROGRAMS = catgconf
+bin_PROGRAMS = radsecproxy-conf
+noinst_LIBRARIES = librsp.a
+
+radsecproxy_SOURCES = main.c
-radsecproxy_SOURCES = radsecproxy.c \
- tlscommon.c \
- gconfig.c \
- util.c \
- debug.c \
- list.c \
- hash.c \
- tlv11.c \
- hostport.c \
- radmsg.c \
- udp.c \
- tcp.c \
- tls.c \
- dtls.c \
- radsecproxy.h \
- tlscommon.h \
- gconfig.h \
- debug.h \
- util.h \
- list.h \
- hash.h \
- tlv11.h \
- hostport.h \
- radmsg.h \
- udp.h \
- tcp.h \
- tls.h \
- dtls.h
+librsp_a_SOURCES = \
+ debug.c debug.h \
+ dtls.c dtls.h \
+ gconfig.c gconfig.h \
+ hash.c hash.h \
+ hostport.c hostport.h \
+ list.c list.h \
+ radmsg.c radmsg.h \
+ radsecproxy.c radsecproxy.h \
+ tcp.c tcp.h \
+ tls.c tls.h \
+ tlscommon.c tlscommon.h \
+ tlv11.c tlv11.h \
+ udp.c udp.h \
+ util.c util.h
+
+if WANT_FTICKS
+librsp_a_SOURCES += fticks.c fticks.h
+endif
-catgconf_SOURCES = debug.c \
- util.c \
- gconfig.c \
- catgconf.c
+radsecproxy_conf_SOURCES = \
+ catgconf.c \
+ debug.c debug.h \
+ gconfig.c gconfig.h \
+ util.c util.h
-radsecproxy_CFLAGS = -g -Wall -fno-strict-aliasing @SSL_CFLAGS@ @TARGET_CFLAGS@
-radsecproxy_LDFLAGS = @SSL_LDFLAGS@ @TARGET_LDFLAGS@
-radsecproxy_LDADD = @SSL_LIBS@
+librsp_a_CFLAGS = \
+ -g -Wall -Werror -fno-strict-aliasing @SSL_CFLAGS@ @TARGET_CFLAGS@
+librsp_a_LDFLAGS = @SSL_LDFLAGS@ @TARGET_LDFLAGS@
+radsecproxy_CFLAGS = $(librsp_a_CFLAGS)
+radsecproxy_LDFLAGS = $(librsp_a_LDFLAGS)
+radsecproxy_LDADD = librsp.a @SSL_LIBS@
-catgconf_CFLAGS = -g -Wall -fno-strict-aliasing @TARGET_CFLAGS@
-catgconf_LDFLAGS = @TARGET_LDFLAGS@
+catgconf_CFLAGS = -g -Wall -fno-strict-aliasing @TARGET_CFLAGS@
+catgconf_LDFLAGS = @TARGET_LDFLAGS@
dist_man_MANS = radsecproxy.1 $(GENMANPAGES)
-EXTRA_DIST = LICENSE THANKS radsecproxy.conf-example radsecproxy.conf.5.xml \
+EXTRA_DIST = \
+ LICENSE THANKS radsecproxy.conf-example radsecproxy.conf.5.xml \
tools/naptr-eduroam.sh tools/radsec-dynsrv.sh tools/README
if HAVE_DOCBOOK2X_MAN