summaryrefslogtreecommitdiff
path: root/lib/radius/Makefile.am
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2012-04-27 17:00:17 +0200
committerLinus Nordberg <linus@nordberg.se>2012-04-27 17:00:17 +0200
commit4b0ff99282a91bba93eec9db37831be73b8134e4 (patch)
tree087509c14291f207260d350c9fabf07c665a4f25 /lib/radius/Makefile.am
parentc562df4b073a288862dd3c4ceaba7d6439f33b45 (diff)
parentefb18a601811888127be69499cf10891aa3a4c37 (diff)
Merge libradsec-new-client.
Diffstat (limited to 'lib/radius/Makefile.am')
-rw-r--r--lib/radius/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/lib/radius/Makefile.am b/lib/radius/Makefile.am
new file mode 100644
index 0000000..92a12cf
--- /dev/null
+++ b/lib/radius/Makefile.am
@@ -0,0 +1,38 @@
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4
+
+INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)
+AM_CFLAGS = -Wall -g
+
+noinst_LTLIBRARIES = libradsec-radius.la
+
+libradsec_radius_la_SOURCES = \
+ attrs.c \
+ crypto.c \
+ custom.c \
+ dict.c \
+ id.c \
+ parse.c \
+ print.c \
+ radpkt.c \
+ static.c \
+ valuepair.c
+
+libradsec_radius_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H
+
+DICTIONARIES = \
+ share/dictionary.txt \
+ share/dictionary.juniper \
+ share/dictionary.microsoft \
+ share/dictionary.ukerna
+
+$(top_srcdir)/include/radsec/radius.h dictionaries.c: ${DICTIONARIES} convert.pl common.pl
+ $(srcdir)/convert.pl ${DICTIONARIES}
+
+static.$(OBJEXT): static.c dictionaries.c
+
+clean-local:
+ rm -f dictionaries.c
+
+$(libradsec_radius_la_SOURCES): $(top_srcdir)/include/radsec/radius.h
+