summaryrefslogtreecommitdiff
path: root/lib/radius/Makefile.am
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2013-01-21 11:02:17 +0100
committerLinus Nordberg <linus@nordberg.se>2013-01-21 11:02:17 +0100
commit35311406413e0418112f7c295fee054a3506cbe8 (patch)
treef463a573a83951fb229a358425e08d9c7484268b /lib/radius/Makefile.am
parentdc61b6b2c2dd3d7b47d83dc6d574bd65dffeadd6 (diff)
parentb8260ee68d9bc60f3204f860cc6919964a6e9464 (diff)
Merge branch 'libradsec-new-client' into libradsec
Diffstat (limited to 'lib/radius/Makefile.am')
-rw-r--r--lib/radius/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/lib/radius/Makefile.am b/lib/radius/Makefile.am
new file mode 100644
index 0000000..92a12cf
--- /dev/null
+++ b/lib/radius/Makefile.am
@@ -0,0 +1,38 @@
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4
+
+INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)
+AM_CFLAGS = -Wall -g
+
+noinst_LTLIBRARIES = libradsec-radius.la
+
+libradsec_radius_la_SOURCES = \
+ attrs.c \
+ crypto.c \
+ custom.c \
+ dict.c \
+ id.c \
+ parse.c \
+ print.c \
+ radpkt.c \
+ static.c \
+ valuepair.c
+
+libradsec_radius_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H
+
+DICTIONARIES = \
+ share/dictionary.txt \
+ share/dictionary.juniper \
+ share/dictionary.microsoft \
+ share/dictionary.ukerna
+
+$(top_srcdir)/include/radsec/radius.h dictionaries.c: ${DICTIONARIES} convert.pl common.pl
+ $(srcdir)/convert.pl ${DICTIONARIES}
+
+static.$(OBJEXT): static.c dictionaries.c
+
+clean-local:
+ rm -f dictionaries.c
+
+$(libradsec_radius_la_SOURCES): $(top_srcdir)/include/radsec/radius.h
+