summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2013-01-21 11:02:17 +0100
committerLinus Nordberg <linus@nordberg.se>2013-01-21 11:02:17 +0100
commit35311406413e0418112f7c295fee054a3506cbe8 (patch)
treef463a573a83951fb229a358425e08d9c7484268b /lib/Makefile.am
parentdc61b6b2c2dd3d7b47d83dc6d574bd65dffeadd6 (diff)
parentb8260ee68d9bc60f3204f860cc6919964a6e9464 (diff)
Merge branch 'libradsec-new-client' into libradsec
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 6b31435..e6f9fb2 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -17,7 +17,7 @@ ACLOCAL_AMFLAGS = -I m4
# library interface is _changed_.
-SUBDIRS = . examples include
+SUBDIRS = radius . include examples
INCLUDES = -I$(srcdir)/include
AM_CFLAGS = -Wall -g
@@ -25,6 +25,7 @@ AM_CFLAGS = -Wall -g
lib_LTLIBRARIES = libradsec.la
libradsec_la_SOURCES = \
+ avp.c \
compat.c \
conf.c \
conn.c \
@@ -52,5 +53,8 @@ libradsec_la_SOURCES += \
rsp_tlscommon.c
endif
+EXTRA_DIST = HACKING LICENSE
+
+libradsec_la_LIBADD = radius/libradsec-radius.la
libradsec_la_LDFLAGS = -version-info 0:0:0 -export-symbols radsec.sym
-libradsec_la_CFLAGS = $(AM_CFLAGS) -DDEBUG -DDEBUG_LEVENT
+libradsec_la_CFLAGS = $(AM_CFLAGS) -DHAVE_CONFIG_H -Werror # -DDEBUG -DDEBUG_LEVENT