summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorLinus Nordberg <linus@nordberg.se>2013-01-22 14:11:32 +0100
committerLinus Nordberg <linus@nordberg.se>2013-01-22 14:11:32 +0100
commit1836d5238f3d7fddd1dda7aa68dc56f39ff073a4 (patch)
tree54105b01b0d26dca07b0fd1be9dd28dbbb82dd47 /lib/Makefile.am
parent95c4d4a42f2b4457c64a87c45c7c170dfba6a7c4 (diff)
Add md5.[ch] for when we are configured without OpenSSL.
This is Solar Designers implementation from http://openwall.info/wiki/people/solar/software/public-domain-source-code/md5 . RS_MD5Transform goes away since it's not in md5.h. It's not used in lib/radius/. Might want to move this into lib/radius/ if we end up not using it in lib/.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 08ace0c..9415c3d 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -42,8 +42,9 @@ libradsec_la_SOURCES = \
util.c
if RS_ENABLE_TLS
-libradsec_la_SOURCES += \
- tls.c
+libradsec_la_SOURCES += tls.c
+else
+libradsec_la_SOURCES += md5.c
endif
EXTRA_DIST = HACKING LICENSE