summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorlinus <linus>2010-03-02 10:26:22 +0000
committerlinus <linus@e88ac4ed-0b26-0410-9574-a7f39faa03bf>2010-03-02 10:26:22 +0000
commit3b64dcc591941c805c7ef427de433c83a6b9df01 (patch)
tree2dc420ef9bd7129ce59c57cccbabea70a2f7ac54 /configure.ac
parent6c308d63772792b64d3468b89d13678c64234252 (diff)
Backported from trunk: Don't pass `-mt' to gcc on Solaris.
git-svn-id: https://svn.testnett.uninett.no/radsecproxy/branches/release-1.3@516 e88ac4ed-0b26-0410-9574-a7f39faa03bf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a49ab91..e57baa5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,7 +50,10 @@ dnl Check if we're on Solaris and set CFLAGS accordingly
AC_CANONICAL_SYSTEM
case "${target_os}" in
solaris*)
- TARGET_CFLAGS="-mt -DSYS_SOLARIS9 -D_POSIX_PTHREAD_SEMANTICS"
+ TARGET_CFLAGS="-DSYS_SOLARIS9 -D_POSIX_PTHREAD_SEMANTICS"
+ if test "$GCC" != yes ; then
+ TARGET_CFLAGS="$TARGET_CFLAGS -mt"
+ fi
TARGET_LDFLAGS="-lpthread -lsocket -lnsl"
;;
*)