summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorvenaas <venaas>2009-03-11 14:33:44 +0000
committervenaas <venaas@e88ac4ed-0b26-0410-9574-a7f39faa03bf>2009-03-11 14:33:44 +0000
commit3adc2f935be9541b01e48c394a93b509553eeda0 (patch)
tree69000e4ccd6818c6c219756ed54f60acb9d7bd51 /configure.ac
parent27c0f9606428773c55340f2d29f207e9767f387b (diff)
improved the solaris depenendent stuff
git-svn-id: https://svn.testnett.uninett.no/radsecproxy/branches/release-1.3@489 e88ac4ed-0b26-0410-9574-a7f39faa03bf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c210736..15f81b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,11 +50,11 @@ dnl Check if we're on Solaris and set CFLAGS accordingly
AC_CANONICAL_SYSTEM
case "${target_os}" in
solaris*)
- TARGET_CFLAGS="-DSYS_SOLARIS9 -D_POSIX_PTHREAD_SEMANTICS"
- TARGET_LDFLAGS="-lsocket"
+ TARGET_CFLAGS="-mt -DSYS_SOLARIS9 -D_POSIX_PTHREAD_SEMANTICS"
+ TARGET_LDFLAGS="-lpthread -lsocket -lnsl"
;;
*)
- TARGET_CFLAGS=""
+ TARGET_CFLAGS="-Wall -pedantic -pthread"
TARGET_LDFLAGS=""
esac
dnl Adding enabled options