summaryrefslogtreecommitdiff
path: root/trust/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'trust/tests/Makefile.am')
-rw-r--r--trust/tests/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/trust/tests/Makefile.am b/trust/tests/Makefile.am
index 90b9fb5..abacab6 100644
--- a/trust/tests/Makefile.am
+++ b/trust/tests/Makefile.am
@@ -1,24 +1,25 @@
include $(top_srcdir)/build/Makefile.tests
-INCLUDES = \
+AM_CPPFLAGS = \
-I$(top_srcdir) \
-I$(srcdir)/.. \
-I$(top_srcdir)/common \
-DDATADIR=\"$(datadir)\" \
-DSYSCONFDIR=\"$(sysconfdir)\" \
- $(CUTEST_CFLAGS)
+ $(TEST_CFLAGS)
noinst_LTLIBRARIES = \
libtestdata.la
libtestdata_la_SOURCES = \
- test-data.c test-data.h
+ test-trust.c test-trust.h
LDADD = \
$(top_builddir)/trust/libtrust-testable.la \
$(top_builddir)/common/libp11-data.la \
$(top_builddir)/common/libp11-library.la \
+ $(top_builddir)/common/libp11-test.la \
$(top_builddir)/common/libp11-common.la \
$(builddir)/libtestdata.la \
$(LIBTASN1_LIBS) \