summaryrefslogtreecommitdiff
path: root/tools/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/tests/Makefile.am')
-rw-r--r--tools/tests/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/tests/Makefile.am b/tools/tests/Makefile.am
index e4dd7ff..6996675 100644
--- a/tools/tests/Makefile.am
+++ b/tools/tests/Makefile.am
@@ -21,6 +21,7 @@ INCLUDES = \
LDADD = \
$(top_builddir)/p11-kit/libp11-kit.la \
$(top_builddir)/common/libp11-data.la \
+ $(top_builddir)/common/libp11-mock.la \
$(top_builddir)/common/libp11-library.la \
$(top_builddir)/common/libp11-compat.la \
$(builddir)/libtestcommon.la \
@@ -37,6 +38,8 @@ libtestcommon_la_SOURCES = \
CHECK_PROGS = \
test-save \
+ test-extract \
+ test-x509 \
$(NULL)
noinst_PROGRAMS = \
@@ -49,4 +52,16 @@ test_save_SOURCES = \
$(TOOLS)/save.c \
$(NULL)
+test_extract_SOURCES = \
+ test-extract.c \
+ $(TOOLS)/extract-info.c \
+ $(NULL)
+
+test_x509_SOURCES = \
+ test-x509.c \
+ $(TOOLS)/extract-info.c \
+ $(TOOLS)/extract-x509.c \
+ $(TOOLS)/save.c \
+ $(NULL)
+
endif # WITH_ASN1