summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 6b988b8..cde804f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -8,22 +8,32 @@ INCLUDES = \
noinst_PROGRAMS = \
hash-test \
+ ptr-array-test \
conf-test \
- uri-test
+ uri-test \
+ pin-test
hash_test_LDADD = \
$(top_builddir)/p11-kit/libp11-kit-testable.la
+ptr_array_test_LDADD = \
+ $(top_builddir)/p11-kit/libp11-kit-testable.la
+
conf_test_LDADD = \
$(top_builddir)/p11-kit/libp11-kit-testable.la
uri_test_LDADD = \
$(top_builddir)/p11-kit/libp11-kit-testable.la
+pin_test_LDADD = \
+ $(top_builddir)/p11-kit/libp11-kit-testable.la
+
check-am:
./hash-test
+ ./ptr-array-test
./conf-test
./uri-test
+ ./pin-test
EXTRA_DIST = \
cutest \