summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am16
1 files changed, 8 insertions, 8 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index ab7d8f8..243b869 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -10,26 +10,26 @@ LDADD = \
$(top_builddir)/p11-kit/libp11-kit-testable.la \
$(LTLIBINTL)
-noinst_PROGRAMS = \
+CHECK_PROGS = \
hash-test \
ptr-array-test \
conf-test \
uri-test \
pin-test \
- print-messages \
test-init
+noinst_PROGRAMS = \
+ print-messages \
+ $(CHECK_PROGS)
+
test_init_SOURCES = \
test-init.c \
mock-module.c mock-module.h
+CHECK_EXECUTABLES = $(CHECK_PROGS:=$(EXEEXT))
+
check-am:
- ./hash-test
- ./ptr-array-test
- ./conf-test
- ./uri-test
- ./pin-test
- ./test-init
+ for prog in $(CHECK_EXECUTABLES); do ./$$prog; done
EXTRA_DIST = \
cutest \