summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 56a5620..5c9e0e4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,16 +2,19 @@
INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/module \
- -Icutest
+ -Icutest \
+ -DSRCDIR=\"$(srcdir)\"
noinst_PROGRAMS = \
- hash-test
-
-hash_test_SOURCES = \
- hash-test.c
+ hash-test \
+ conf-test
hash_test_LDADD = \
$(top_builddir)/module/libp11-kit-testable.la
+conf_test_LDADD = \
+ $(top_builddir)/module/libp11-kit-testable.la
+
check-am:
./hash-test
+ ./conf-test