summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
index 6496e8d..573bf61 100644
--- a/p11-kit/Makefile.am
+++ b/p11-kit/Makefile.am
@@ -174,19 +174,24 @@ p11_kit_remote_LDADD = \
libp11-kit.la \
$(NULL)
-if !OS_WIN32
private_PROGRAMS += p11-kit-server
p11_kit_server_SOURCES = \
p11-kit/server.c \
$(NULL)
+if OS_WIN32
+ WIN32_LIBS = -ladvapi32
+else
+ WIN32_LIBS =
+endif
+
p11_kit_server_LDADD = \
libp11-tool.la \
libp11-common.la \
libp11-kit.la \
+ $(WIN32_LIBS) \
$(NULL)
-endif
# Tests ----------------------------------------------------------------