summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3511800..382c96a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -398,7 +398,17 @@ echo $PACKAGE_VERSION | tr '.' ' ' | while read major minor unused; do
break
done
-eval SHLEXT=$shrext_cmds
+case "$host" in
+*-*-darwin*)
+ # It seems like libtool lies about this see:
+ # https://bugs.freedesktop.org/show_bug.cgi?id=57714
+ SHLEXT='.so'
+ ;;
+*)
+ eval SHLEXT=$shrext_cmds
+ ;;
+esac
+
AC_DEFINE_UNQUOTED(SHLEXT, ["$SHLEXT"], [File extension for shared libraries])
AC_SUBST(SHLEXT)