summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e843dfa..ef6f06f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,9 +72,10 @@ if test "$os_unix" = "yes"; then
[AC_MSG_ERROR([could not find dlopen])])
AC_SEARCH_LIBS([nanosleep], [rt], [],
[AC_MSG_ERROR([could not find nanosleep])])
+
+ # These are thngs we can work around
AC_CHECK_MEMBERS([struct dirent.d_type],,,[#include <dirent.h>])
- AC_CHECK_FUNCS([getprogname getexecname memdup])
- AC_CHECK_FUNCS([getprogname getexecname strnstr memdup])
+ AC_CHECK_FUNCS([getprogname getexecname basename mkstemp mkdtemp])
# Check if these are declared and/or available to link against
AC_CHECK_DECLS([program_invocation_short_name])