summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b6d21d0..a42d205 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,8 +65,10 @@ if test "$os_unix" = "yes"; then
[AC_MSG_ERROR([could not find pthread_mutex_lock])])
AC_SEARCH_LIBS([dlopen], [dl dld], [],
[AC_MSG_ERROR([could not find dlopen])])
+ AC_SEARCH_LIBS([nanosleep], [rt], [],
+ [AC_MSG_ERROR([could not find nanosleep])])
AC_CHECK_MEMBERS([struct dirent.d_type],,,[#include <dirent.h>])
- AC_CHECK_HEADERS([err.h])
+ AC_CHECK_HEADERS([err.h errno.h])
AC_CHECK_FUNCS([getprogname getexecname])
# Check if these are declared and/or available to link against