summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6ee6404..d4ff1ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,9 +73,9 @@ AC_HEADER_STDBOOL
AC_CHECK_SIZEOF([unsigned long])
if test "$os_unix" = "yes"; then
- AC_CHECK_FUNC([pthread_create], , [
- AC_CHECK_LIB(pthread, pthread_create, , [
- AC_MSG_ERROR([could not find pthread_create])
+ AC_CHECK_FUNC([pthread_mutex_lock], , [
+ AC_SEARCH_LIBS([pthread_mutex_lock], [pthread], , [
+ AC_MSG_ERROR([could not find pthread_mutex_lock])
])
])