summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e812efe..89e5f99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,7 +96,7 @@ if test "$os_unix" = "yes"; then
])
# These are thngs we can work around
- AC_CHECK_HEADERS([locale.h sys/resource.h])
+ AC_CHECK_HEADERS([locale.h sys/resource.h ucred.h])
AC_CHECK_MEMBERS([struct dirent.d_type],,,[#include <dirent.h>])
AC_CHECK_FUNCS([getprogname getexecname basename mkstemp mkdtemp])
AC_CHECK_FUNCS([getauxval issetugid getresuid secure_getenv])
@@ -104,6 +104,7 @@ if test "$os_unix" = "yes"; then
AC_CHECK_FUNCS([fdwalk])
AC_CHECK_FUNCS([setenv])
AC_CHECK_FUNCS([getpeereid])
+ AC_CHECK_FUNCS([getpeerucred])
# Required functions
AC_CHECK_FUNCS([gmtime_r],