summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 1 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 318db2b..492288a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -115,21 +115,7 @@ if test "$os_unix" = "yes"; then
AC_CHECK_FUNCS([setenv])
AC_CHECK_FUNCS([getpeereid])
AC_CHECK_FUNCS([getpeerucred])
-
- # Check if issetugid() is available and has compatible behavior with OpenBSD
- AC_CHECK_FUNCS([issetugid], [
- AC_CACHE_CHECK([whether issetugid() can detect setuid/setgid],
- [ac_cv_issetugid_openbsd],
- [ac_cv_issetugid_openbsd=no
- AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <unistd.h>]],
- [[return issetugid ();]])],
- [chmod 02777 ./conftest$EXEEXT; ./conftest$EXEEXT || ac_cv_issetugid_openbsd=yes],
- [ac_cv_issetugid_openbsd=no],
- [ac_cv_issetugid_openbsd="guessing no"])])
- if test "$ac_cv_issetugid_openbsd" = yes; then
- AC_DEFINE([HAVE_ISSETUGID_OPENBSD], [1], [Whether issetugid() has compatible behavior with OpenBSD])
- fi
- ])
+ AC_CHECK_FUNCS([issetugid])
AC_CACHE_CHECK([for thread-local storage class],
[ac_cv_tls_keyword],