summaryrefslogtreecommitdiff
path: root/common/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/tests/Makefile.am')
-rw-r--r--common/tests/Makefile.am14
1 files changed, 5 insertions, 9 deletions
diff --git a/common/tests/Makefile.am b/common/tests/Makefile.am
index 11f2369..af61786 100644
--- a/common/tests/Makefile.am
+++ b/common/tests/Makefile.am
@@ -11,21 +11,17 @@ INCLUDES = \
-I$(COMMON) \
$(CUTEST_CFLAGS)
-LDADD = $(CUTEST_LIBS)
+LDADD = \
+ $(top_builddir)/common/libp11-library.la \
+ $(top_builddir)/common/libp11-compat.la \
+ $(CUTEST_LIBS) \
+ $(NULL)
CHECK_PROGS = \
test-dict \
test-array \
$(NULL)
-test_dict_SOURCES = \
- test-dict.c \
- $(COMMON)/dict.c
-
-test_array_SOURCES = \
- test-array.c \
- $(COMMON)/array.c
-
noinst_PROGRAMS = \
$(CHECK_PROGS)