summaryrefslogtreecommitdiff
path: root/build/certs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'build/certs/Makefile.am')
-rw-r--r--build/certs/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/build/certs/Makefile.am b/build/certs/Makefile.am
index 1c30521..4428a2e 100644
--- a/build/certs/Makefile.am
+++ b/build/certs/Makefile.am
@@ -16,6 +16,15 @@ prepare-certs:
openssl x509 -in cacert3.der -inform DER -out $(TRUST)/files/cacert3-trusted.pem \
-addtrust clientAuth -addtrust serverAuth -addreject emailProtection \
-setalias "Custom Label"
+ cp $(TRUST)/files/cacert3-trusted.pem $(TOOLS)/files/cacert3-trusted-client-server-alias.pem
+ openssl x509 -in cacert3.der -inform DER -out $(TOOLS)/files/cacert3-trusted-alias.pem \
+ -setalias "Custom Label"
+ openssl x509 -in cacert3.der -inform DER -out $(TOOLS)/files/cacert3-distrust-all.pem \
+ -addreject serverAuth -addreject clientAuth -addreject codeSigning \
+ -addreject emailProtection -addreject ipsecEndSystem -addreject ipsecTunnel \
+ -addreject ipsecUser -addreject timeStamping
+ cat $(TOOLS)/files/cacert3-trusted-client-server-alias.pem \
+ $(TOOLS)/files/cacert3-trusted-alias.pem > $(TOOLS)/files/cacert3-trusted-multiple.pem
cp -v cacert-ca.der $(TRUST)/certificates
cp -v cacert-ca.der $(TRUST)/files
openssl x509 -in redhat-newca.der -inform DER -out $(TRUST)/files/distrusted.pem \