summaryrefslogtreecommitdiff
path: root/trust/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-03-20 14:35:27 +0100
committerStef Walter <stefw@gnome.org>2013-03-20 15:26:35 +0100
commite075585ef1cffc988894b4efbf3d14d5e55dcdcc (patch)
treec035faa3bd8787dba48cc99e544ecf6460187661 /trust/tests/Makefile.am
parentfc562261c6bbb35dfed585a78fdec9a408b981c7 (diff)
trust: Rework index to be faster and more usable
The index now uses a sort of cross between a hash table and a bloom filter internally to select matching items. This is needed for the massive amount of lookups we want to do during loading. In addition make p11_index_find() and p11_index_replace() easier to use.
Diffstat (limited to 'trust/tests/Makefile.am')
-rw-r--r--trust/tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/trust/tests/Makefile.am b/trust/tests/Makefile.am
index aedc6f3..4617546 100644
--- a/trust/tests/Makefile.am
+++ b/trust/tests/Makefile.am
@@ -29,14 +29,15 @@ LDADD = \
CHECK_PROGS = \
test-persist \
- test-parser \
test-index \
+ test-parser \
test-builder \
test-token \
test-module \
$(NULL)
noinst_PROGRAMS = \
+ frob-pow \
frob-token \
frob-nss-trust \
$(CHECK_PROGS)