summaryrefslogtreecommitdiff
path: root/trust/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2017-01-11 09:32:19 +0100
committerDaiki Ueno <ueno@gnu.org>2017-02-17 10:25:55 +0100
commit0684cd7b7f815b411ea5041c021f92ca5ef42606 (patch)
treeffb7006ea208c5574441d51ac82edec115474460 /trust/Makefile.am
parentc28ff652e5d6c6ddff513716e22064e0e17a58d3 (diff)
rpc: Add PKCS#11 module that connects to socket
This patch adds a PKCS#11 module that connects to the p11-kit server exposed on the filesystem. The filename of the socket is determined in the following order: - $P11_KIT_SERVER_ADDRESS, if the envvar is available - $XDG_RUNTIME_DIR/p11-kit/pkcs11, if the envvar is available - /run/$(id -u)/p11-kit/pkcs11, if /run/$(id -u) exists - /var/run/$(id -u)/p11-kit/pkcs11, if /var/run/$(id -u) exists - ~/.cache/p11-kit/pkcs11. Note that the program loading this module may have called setuid() and secure_getenv() which we use for fetching envvars could return NULL.
Diffstat (limited to 'trust/Makefile.am')
-rw-r--r--trust/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/trust/Makefile.am b/trust/Makefile.am
index 6df75a1..2ae62d4 100644
--- a/trust/Makefile.am
+++ b/trust/Makefile.am
@@ -38,8 +38,7 @@ TRUST_SRCS = \
configdir = $(p11_package_config_modules)
config_DATA = trust/p11-kit-trust.module
-moduledir = $(p11_module_path)
-module_LTLIBRARIES = \
+module_LTLIBRARIES += \
p11-kit-trust.la
p11_kit_trust_la_CFLAGS = \