summaryrefslogtreecommitdiff
path: root/tools/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@thewalter.net>2013-06-24 13:34:30 +0200
committerStef Walter <stef@thewalter.net>2013-06-25 13:27:01 +0200
commit069c52a10cc4c4c06de8a4d83ddb3755e40be7a4 (patch)
tree039013d0a4c0e53050204c92d4028e2419f80461 /tools/tests/Makefile.am
parent5489a1456c5a6f320bd2b3aa849f36f10d538e81 (diff)
Reorganize various components
* p11-kit library and tool in the p11-kit/ subdirectory * trust module and new trust tool in trust/ subdirectory * No more tools/ subdirectory * Lots less in the common/ subdirectory
Diffstat (limited to 'tools/tests/Makefile.am')
-rw-r--r--tools/tests/Makefile.am84
1 files changed, 0 insertions, 84 deletions
diff --git a/tools/tests/Makefile.am b/tools/tests/Makefile.am
deleted file mode 100644
index 9a5ab73..0000000
--- a/tools/tests/Makefile.am
+++ /dev/null
@@ -1,84 +0,0 @@
-
-include $(top_srcdir)/build/Makefile.tests
-
-EXTRA_DIST = files
-
-if WITH_ASN1
-
-COMMON = $(top_srcdir)/common
-TOOLS = $(top_srcdir)/tools
-
-TEST_RUNNER = libtool --mode=execute
-
-AM_CPPFLAGS = \
- -I$(top_srcdir) \
- -I$(top_srcdir)/p11-kit \
- -I$(srcdir)/.. \
- -I$(COMMON) \
- -DP11_KIT_FUTURE_UNSTABLE_API \
- $(LIBTASN1_CFLAGS) \
- $(TEST_CFLAGS) \
- $(NULL)
-
-LDADD = \
- $(top_builddir)/p11-kit/libp11-kit.la \
- $(top_builddir)/common/libp11-data.la \
- $(top_builddir)/common/libp11-test.la \
- $(top_builddir)/common/libp11-common.la \
- $(builddir)/libtestcommon.la \
- $(LIBTASN1_LIBS) \
- $(LTLIBINTL) \
- $(CUTEST_LIBS) \
- $(NULL)
-
-noinst_LTLIBRARIES = \
- libtestcommon.la
-
-libtestcommon_la_SOURCES = \
- test-tools.c test-tools.h
-
-CHECK_PROGS = \
- test-save \
- test-extract \
- test-x509 \
- test-pem \
- test-openssl \
- $(NULL)
-
-noinst_PROGRAMS = \
- $(CHECK_PROGS)
-
-TESTS = $(CHECK_PROGS)
-
-test_save_SOURCES = \
- test-save.c \
- $(TOOLS)/save.c \
- $(NULL)
-
-test_extract_SOURCES = \
- test-extract.c \
- $(TOOLS)/extract-info.c \
- $(NULL)
-
-test_x509_SOURCES = \
- test-x509.c \
- $(TOOLS)/extract-info.c \
- $(TOOLS)/extract-x509.c \
- $(TOOLS)/save.c \
- $(NULL)
-
-test_pem_SOURCES = \
- test-pem.c \
- $(TOOLS)/extract-info.c \
- $(TOOLS)/extract-pem.c \
- $(TOOLS)/save.c \
- $(NULL)
-
-test_openssl_SOURCES = \
- test-openssl.c \
- $(TOOLS)/extract-info.c \
- $(TOOLS)/extract-openssl.c \
- $(TOOLS)/save.c \
- $(NULL)
-
-endif # WITH_ASN1