summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-01-29 11:43:09 +0100
committerStef Walter <stefw@gnome.org>2013-02-05 09:42:34 +0100
commita9790a21302f47016a88ba9a2c904bed11efb388 (patch)
tree0ecb7d60aef9f03a3d0dc2aa9c93cc0739c0af20 /tools/Makefile.am
parent15163fb9b7b03543da02d74d75d0f49c314f1c33 (diff)
Make the p11-kit tool have distinct commands
* Change the -l argument into the list-modules command. * Add proper functions for printing usage * Support for external commands in the path or /usr/share/p11-kit
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 44b8432..43adf56 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -6,17 +6,22 @@ INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/common \
-I$(top_srcdir)/p11-kit \
- -DSRCDIR=\"$(srcdir)\"
+ -DSRCDIR=\"$(srcdir)\" \
+ -DPKGDATADIR=\"$(pkgdatadir)\" \
+ -DP11_KIT_FUTURE_UNSTABLE_API \
+ $(NULL)
bin_PROGRAMS = \
p11-kit
p11_kit_SOURCES = \
- p11-kit.c \
+ list.c \
+ tool.c tool.h \
$(NULL)
p11_kit_LDADD = \
$(top_builddir)/p11-kit/libp11-kit.la \
+ $(top_builddir)/common/libp11-library.la \
$(top_builddir)/common/libp11-compat.la \
$(LTLIBINTL) \
$(NULL)