summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-10-10 12:08:35 +0200
committerStef Walter <stefw@collabora.co.uk>2011-10-10 12:16:03 +0200
commitd5a004ded8a0acdb7aa2100b8e116f19d0d9e402 (patch)
treee42565fb077515a72a417b06afb5dae5047246cd /tests/Makefile.am
parent591c1c14f2ebbcbc3f621456e31e2af1d26820b8 (diff)
Don't allow recursive calling of C_Initialize on a given module.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 71e31a3..65828bf 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -16,20 +16,26 @@ noinst_PROGRAMS = \
conf-test \
uri-test \
pin-test \
+ print-messages \
test-fork \
- print-messages
+ test-recursive
test_fork_SOURCES = \
test-fork.c \
mock-module.c mock-module.h
+test_recursive_SOURCES = \
+ test-recursive.c \
+ mock-module.c mock-module.h
+
check-am:
./hash-test
./ptr-array-test
./conf-test
./uri-test
./pin-test
- ./p11-test
+ ./test-fork
+ ./test-recursive
EXTRA_DIST = \
cutest \