summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-01-30 08:26:23 -0600
committerStef Walter <stefw@collabora.co.uk>2011-01-30 08:26:23 -0600
commit14dfb79ca65dd80e117103c4f8852ae2b4a419a0 (patch)
tree2b568bac82b2dae2299e9030686b7f5c78da7c3d /tests/Makefile.am
parent4375e297b19bc2177e17cc5616e75d96be053328 (diff)
Configuration tests.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 56a5620..5c9e0e4 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,16 +2,19 @@
INCLUDES = \
-I$(top_srcdir) \
-I$(top_srcdir)/module \
- -Icutest
+ -Icutest \
+ -DSRCDIR=\"$(srcdir)\"
noinst_PROGRAMS = \
- hash-test
-
-hash_test_SOURCES = \
- hash-test.c
+ hash-test \
+ conf-test
hash_test_LDADD = \
$(top_builddir)/module/libp11-kit-testable.la
+conf_test_LDADD = \
+ $(top_builddir)/module/libp11-kit-testable.la
+
check-am:
./hash-test
+ ./conf-test