summaryrefslogtreecommitdiff
path: root/p11-kit/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-01-10 16:51:31 +0100
committerStef Walter <stefw@gnome.org>2013-05-16 20:01:28 +0200
commitff853bd7902e271256cada4a1b20a3d46b519b69 (patch)
tree20ef6544b8c33fc72d88064b99a59d5885c17477 /p11-kit/tests/Makefile.am
parenta7af75a31010109529a9edddc825538884f326ca (diff)
Use libffi to implement mixins for managed code
* This allows us to call into subclassed PKCS#11 modules as if they were plain old PKCS#11 modules * libffi is an optional dependency
Diffstat (limited to 'p11-kit/tests/Makefile.am')
-rw-r--r--p11-kit/tests/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/p11-kit/tests/Makefile.am b/p11-kit/tests/Makefile.am
index c7b87ae..715fca0 100644
--- a/p11-kit/tests/Makefile.am
+++ b/p11-kit/tests/Makefile.am
@@ -26,6 +26,13 @@ CHECK_PROGS = \
test-iter \
$(NULL)
+if WITH_FFI
+
+CHECK_PROGS += \
+ test-virtual
+
+endif
+
noinst_PROGRAMS = \
print-messages \
$(CHECK_PROGS)