summaryrefslogtreecommitdiff
path: root/p11-kit/tests/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2013-04-02 20:40:53 +0200
committerStef Walter <stefw@gnome.org>2013-04-03 10:39:09 +0200
commitfcc3a83cc4d540bc2c4096524b5e8003046ba561 (patch)
tree5bc566d6813448f83269797ce05aadeb02cdf36f /p11-kit/tests/Makefile.am
parentae7dd1be6d431f25b101bc7e2b3fa373a8cbb47b (diff)
Separate library init from message code
Put library init/uninit code its into their own statically linked library so that they don't get linked into the p11-kit executable. Refactor the message code so that the library initialization can plug in its per thread message buffer. https://bugs.freedesktop.org/show_bug.cgi?id=63046
Diffstat (limited to 'p11-kit/tests/Makefile.am')
-rw-r--r--p11-kit/tests/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/p11-kit/tests/Makefile.am b/p11-kit/tests/Makefile.am
index bc96bf4..c7b87ae 100644
--- a/p11-kit/tests/Makefile.am
+++ b/p11-kit/tests/Makefile.am
@@ -12,8 +12,7 @@ INCLUDES = \
LDADD = \
$(top_builddir)/p11-kit/libp11-kit-testable.la \
$(top_builddir)/common/libp11-mock.la \
- $(top_builddir)/common/libp11-library.la \
- $(top_builddir)/common/libp11-compat.la \
+ $(top_builddir)/common/libp11-common.la \
$(CUTEST_LIBS) \
$(LTLIBINTL)
@@ -47,8 +46,7 @@ mock_one_la_CFLAGS = \
mock_one_la_LIBADD = \
$(top_builddir)/common/libp11-mock.la \
- $(top_builddir)/common/libp11-library.la \
- $(top_builddir)/common/libp11-compat.la \
+ $(top_builddir)/common/libp11-common.la \
$(NULL)
mock_one_la_LDFLAGS = \