summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2017-03-09 17:45:31 +0100
committerDaiki Ueno <ueno@gnu.org>2017-05-25 14:13:01 +0200
commitdd673f20e1ab4916f7565fe055b09433aa88a9b0 (patch)
tree5b8e38ae289b97aec6d183a7c077c0df7bf18b6e /p11-kit/Makefile.am
parentda7f0d65355089f4919bcdffca98bd833258db04 (diff)
server: Port to Windows
Instead of a Unix domain socket on Unix, use a named pipe on Windows.
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
index 6496e8d..573bf61 100644
--- a/p11-kit/Makefile.am
+++ b/p11-kit/Makefile.am
@@ -174,19 +174,24 @@ p11_kit_remote_LDADD = \
libp11-kit.la \
$(NULL)
-if !OS_WIN32
private_PROGRAMS += p11-kit-server
p11_kit_server_SOURCES = \
p11-kit/server.c \
$(NULL)
+if OS_WIN32
+ WIN32_LIBS = -ladvapi32
+else
+ WIN32_LIBS =
+endif
+
p11_kit_server_LDADD = \
libp11-tool.la \
libp11-common.la \
libp11-kit.la \
+ $(WIN32_LIBS) \
$(NULL)
-endif
# Tests ----------------------------------------------------------------