summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2017-10-06 10:58:50 +0200
committerDaiki Ueno <ueno@gnu.org>2017-10-06 16:56:58 +0200
commit96a3d3e6371785f846bc72c2a701a1eb67c89b77 (patch)
tree3697ec61b8ec9fc8aa17da4f248ef7417887f634 /p11-kit/Makefile.am
parent031912fa844c4f3da327c8b2578d9d9ce2a6473e (diff)
server: Better shell integration
This adds -k, -c, and -s options to the "p11-kit server" command, which allows you to terminate the server process, select which C-shell or Bourne shell command line is printed on startup, respectively.
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
index f2571d2..955719a 100644
--- a/p11-kit/Makefile.am
+++ b/p11-kit/Makefile.am
@@ -208,6 +208,10 @@ check_PROGRAMS += \
test-rpc \
$(NULL)
+if !OS_WIN32
+check_SCRIPTS += p11-kit/test-server.sh
+endif
+
test_conf_SOURCES = p11-kit/test-conf.c
test_conf_LDADD = $(p11_kit_LIBS)
@@ -306,4 +310,5 @@ mock_five_la_LIBADD = $(mock_one_la_LIBADD)
EXTRA_DIST += \
p11-kit/fixtures \
p11-kit/test-mock.c \
+ $(check_SCRIPTS) \
$(NULL)