summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-03-31 12:41:43 +0200
committerStef Walter <stefw@collabora.co.uk>2011-03-31 12:41:43 +0200
commit479cbd55ee5739d3cd2566379575451dbecf4c54 (patch)
treeec6730dfbd1855dc6193fe2b5df2d09e208200a3 /p11-kit/Makefile.am
parent6132cd99c39739ef5360e41e92f22d287007577e (diff)
Documentation and API cleanup.
* Rename source directory * More consistent with return values from URI functions. * Allow formatting URI to take a uri type.
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
new file mode 100644
index 0000000..989f482
--- /dev/null
+++ b/p11-kit/Makefile.am
@@ -0,0 +1,40 @@
+
+incdir = $(includedir)/p11-kit
+
+inc_HEADERS = \
+ p11-kit.h \
+ p11-kit-uri.h \
+ pkcs11.h
+
+MODULE_SRCS = \
+ conf.c conf.h \
+ hash.c hash.h \
+ util.c util.h \
+ p11-kit-lib.c \
+ p11-kit-proxy.c \
+ p11-kit-private.h \
+ p11-kit-messages.c \
+ p11-kit-uri.c \
+ $(inc_HEADERS)
+
+lib_LTLIBRARIES = \
+ libp11-kit.la
+
+noinst_LTLIBRARIES = \
+ libp11-kit-testable.la
+
+libp11_kit_la_LDFLAGS = \
+ -no-undefined -export-symbols-regex '^C_GetFunctionList|^p11_kit_'
+
+libp11_kit_la_SOURCES = $(MODULE_SRCS)
+
+libp11_kit_testable_la_LDFLAGS = \
+ -no-undefined
+
+libp11_kit_testable_la_SOURCES = $(MODULE_SRCS)
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = p11-kit.pc
+
+EXTRA_DIST = \
+ p11-kit.pc.in \ No newline at end of file