summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2012-12-06 22:42:02 +0100
committerStef Walter <stefw@gnome.org>2013-01-09 13:49:44 +0100
commit3d503948450d69293a3fdfec096e398fedf714f2 (patch)
tree17b68364a71602b846c5122c8007b86fd51812c2 /p11-kit/Makefile.am
parentc343f355b6abfe65adc696b57b18dc57c834acbc (diff)
Move debug and library code into the common/ subdirectory
Start using p11_ as our internal prefix rather than _p11_. We explicitly export p11_kit_ so this is fine as far as visibility. Move the threading, mutex, and module compat, dict, and array code into the common directory too. Take this opportunity to clean up a bit of internal API as well, since so many lines are being touched internally.
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am54
1 files changed, 33 insertions, 21 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
index 2985d85..11d5fae 100644
--- a/p11-kit/Makefile.am
+++ b/p11-kit/Makefile.am
@@ -1,8 +1,12 @@
NULL =
+SUBDIRS = . tests
+
+COMMON = $(top_srcdir)/common
+
INCLUDES = \
-I$(top_srcdir) \
- -I$(top_srcdir)/common \
+ -I$(COMMON) \
-DP11_KIT_FUTURE_UNSTABLE_API \
$(NULL)
@@ -15,19 +19,24 @@ inc_HEADERS = \
pkcs11.h
MODULE_SRCS = \
- util.c util.h \
+ util.c \
conf.c conf.h \
- debug.c debug.h \
- hashmap.c hashmap.h \
modules.c \
pin.c \
proxy.c \
private.h \
- ptr-array.c ptr-array.h \
messages.c \
uri.c \
- $(top_srcdir)/common/compat.c \
- $(top_srcdir)/common/compat.h \
+ $(COMMON)/array.c \
+ $(COMMON)/array.h \
+ $(COMMON)/compat.c \
+ $(COMMON)/compat.h \
+ $(COMMON)/debug.c \
+ $(COMMON)/debug.h \
+ $(COMMON)/dict.c \
+ $(COMMON)/dict.h \
+ $(COMMON)/library.c \
+ $(COMMON)/library.h \
$(inc_HEADERS)
lib_LTLIBRARIES = \
@@ -62,31 +71,34 @@ libp11_kit_testable_la_SOURCES = $(MODULE_SRCS)
if OS_WIN32
libp11_kit_testable_la_CFLAGS = \
- -DP11_SYSTEM_CONFIG_FILE=\""$(abs_top_srcdir)/tests/files/system-pkcs11.conf"\" \
- -DP11_SYSTEM_CONFIG_MODULES=\""$(abs_top_srcdir)/tests/files/system-modules/win32"\" \
- -DP11_USER_CONFIG_FILE=\""$(abs_top_srcdir)/tests/files/user-pkcs11.conf"\" \
- -DP11_USER_CONFIG_MODULES=\""$(abs_top_srcdir)/tests/files/user-modules/win32"\" \
- -DP11_MODULE_PATH=\""$(abs_top_builddir)/tests/.libs"\" \
+ -DP11_SYSTEM_CONFIG_FILE=\""$(abs_top_srcdir)/p11-kit/tests/files/system-pkcs11.conf"\" \
+ -DP11_SYSTEM_CONFIG_MODULES=\""$(abs_top_srcdir)/p11-kit/tests/files/system-modules/win32"\" \
+ -DP11_USER_CONFIG_FILE=\""$(abs_top_srcdir)/p11-kit/tests/files/user-pkcs11.conf"\" \
+ -DP11_USER_CONFIG_MODULES=\""$(abs_top_srcdir)/p11-kit/tests/files/user-modules/win32"\" \
+ -DP11_MODULE_PATH=\""$(abs_top_builddir)/p11-kit/tests/.libs"\" \
$(NULL)
else
libp11_kit_testable_la_CFLAGS = \
- -DP11_SYSTEM_CONFIG_FILE=\""$(abs_top_srcdir)/tests/files/system-pkcs11.conf"\" \
- -DP11_SYSTEM_CONFIG_MODULES=\""$(abs_top_srcdir)/tests/files/system-modules"\" \
- -DP11_USER_CONFIG_FILE=\""$(abs_top_srcdir)/tests/files/user-pkcs11.conf"\" \
- -DP11_USER_CONFIG_MODULES=\""$(abs_top_srcdir)/tests/files/user-modules"\" \
- -DP11_MODULE_PATH=\""$(abs_top_builddir)/tests/.libs"\" \
+ -DP11_SYSTEM_CONFIG_FILE=\""$(abs_top_srcdir)/p11-kit/tests/files/system-pkcs11.conf"\" \
+ -DP11_SYSTEM_CONFIG_MODULES=\""$(abs_top_srcdir)/p11-kit/tests/files/system-modules"\" \
+ -DP11_USER_CONFIG_FILE=\""$(abs_top_srcdir)/p11-kit/tests/files/user-pkcs11.conf"\" \
+ -DP11_USER_CONFIG_MODULES=\""$(abs_top_srcdir)/p11-kit/tests/files/user-modules"\" \
+ -DP11_MODULE_PATH=\""$(abs_top_builddir)/p11-kit/tests/.libs"\" \
$(NULL)
endif
libp11_kit_compat_la_SOURCES = \
- debug.c debug.h \
messages.c \
- util.c util.h \
- $(top_srcdir)/common/compat.c \
- $(top_srcdir)/common/compat.h
+ $(COMMON)/compat.c \
+ $(COMMON)/compat.h \
+ $(COMMON)/debug.c \
+ $(COMMON)/debug.h \
+ $(COMMON)/library.c \
+ $(COMMON)/library.h \
+ $(NULL)
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = p11-kit-1.pc