summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2019-06-01 12:51:39 +0200
committerDaiki Ueno <ueno@gnu.org>2019-06-18 14:17:28 +0200
commit084347319f6e832ec2c36d7b27a64c8f2614f084 (patch)
tree921d6c9167843414446aad70ef23cd0a898e1243 /p11-kit/Makefile.am
parent6bebd5747aa49d4a124d23d4967f65a771799fe5 (diff)
build: Move check_PROGRAMS into subdirectories
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am32
1 files changed, 16 insertions, 16 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
index 7f4ce44..b649119 100644
--- a/p11-kit/Makefile.am
+++ b/p11-kit/Makefile.am
@@ -232,57 +232,57 @@ p11_kit_p11_kit_LDADD = \
$(LTLIBINTL) \
$(NULL)
-private_PROGRAMS += p11-kit-remote
+private_PROGRAMS += p11-kit/p11-kit-remote
-p11_kit_remote_SOURCES = \
+p11_kit_p11_kit_remote_SOURCES = \
p11-kit/remote.c \
$(NULL)
-p11_kit_remote_LDADD = \
+p11_kit_p11_kit_remote_LDADD = \
libp11-tool.la \
libp11-common.la \
libp11-kit.la \
$(NULL)
-check_PROGRAMS += p11-kit-remote-testable
-p11_kit_remote_testable_SOURCES = $(p11_kit_remote_SOURCES)
+check_PROGRAMS += p11-kit/p11-kit-remote-testable
+p11_kit_p11_kit_remote_testable_SOURCES = $(p11_kit_p11_kit_remote_SOURCES)
-p11_kit_remote_testable_LDADD = \
+p11_kit_p11_kit_remote_testable_LDADD = \
libp11-tool.la \
libp11-common.la \
libp11-kit-testable.la \
$(NULL)
-private_PROGRAMS += p11-kit-server
+private_PROGRAMS += p11-kit/p11-kit-server
-p11_kit_server_SOURCES = \
+p11_kit_p11_kit_server_SOURCES = \
p11-kit/server.c \
$(NULL)
-p11_kit_server_LDADD = \
+p11_kit_p11_kit_server_LDADD = \
libp11-tool.la \
libp11-common.la \
libp11-kit.la \
$(LIBSYSTEMD_LIBS) \
$(NULL)
-p11_kit_server_CFLAGS = \
+p11_kit_p11_kit_server_CFLAGS = \
-DP11_KIT_REMOTE=\"p11-kit-remote\" \
$(COMMON_CFLAGS) \
$(LIBSYSTEMD_CFLAGS) \
$(NULL)
-check_PROGRAMS += p11-kit-server-testable
-p11_kit_server_testable_SOURCES = $(p11_kit_server_SOURCES)
+check_PROGRAMS += p11-kit/p11-kit-server-testable
+p11_kit_p11_kit_server_testable_SOURCES = $(p11_kit_p11_kit_server_SOURCES)
-p11_kit_server_testable_LDADD = \
+p11_kit_p11_kit_server_testable_LDADD = \
libp11-tool.la \
libp11-common.la \
libp11-kit-testable.la \
$(LIBSYSTEMD_LIBS) \
$(NULL)
-p11_kit_server_testable_CFLAGS = \
+p11_kit_p11_kit_server_testable_CFLAGS = \
-DP11_KIT_REMOTE=\"p11-kit-remote-testable\" \
$(COMMON_CFLAGS) \
$(LIBSYSTEMD_CFLAGS) \
@@ -368,8 +368,8 @@ test_util_SOURCES = p11-kit/test-util.c
test_util_LDADD = $(p11_kit_LIBS)
check_PROGRAMS += \
- print-messages \
- frob-setuid
+ p11-kit/print-messages \
+ p11-kit/frob-setuid
print_messages_SOURCES = p11-kit/print-messages.c
print_messages_LDADD = $(p11_kit_LIBS)