summaryrefslogtreecommitdiff
path: root/p11-kit/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stef@thewalter.net>2013-06-24 13:34:30 +0200
committerStef Walter <stef@thewalter.net>2013-06-25 13:27:01 +0200
commit069c52a10cc4c4c06de8a4d83ddb3755e40be7a4 (patch)
tree039013d0a4c0e53050204c92d4028e2419f80461 /p11-kit/Makefile.am
parent5489a1456c5a6f320bd2b3aa849f36f10d538e81 (diff)
Reorganize various components
* p11-kit library and tool in the p11-kit/ subdirectory * trust module and new trust tool in trust/ subdirectory * No more tools/ subdirectory * Lots less in the common/ subdirectory
Diffstat (limited to 'p11-kit/Makefile.am')
-rw-r--r--p11-kit/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/p11-kit/Makefile.am b/p11-kit/Makefile.am
index 2e08e84..a8f7da7 100644
--- a/p11-kit/Makefile.am
+++ b/p11-kit/Makefile.am
@@ -8,6 +8,8 @@ COMMON = $(top_srcdir)/common
AM_CPPFLAGS = \
-I$(top_srcdir) \
-I$(COMMON) \
+ -DSRCDIR=\"$(srcdir)\" \
+ -DPRIVATEDIR=\"$(privatedir)\" \
-DP11_KIT_FUTURE_UNSTABLE_API \
$(NULL)
@@ -113,3 +115,21 @@ EXTRA_DIST = \
install-exec-hook:
$(LN_S) -f `readlink $(DESTDIR)$(libdir)/libp11-kit.so` $(DESTDIR)$(libdir)/p11-kit-proxy.so
$(MKDIR_P) $(DESTDIR)$(p11_package_config_modules)
+
+bin_PROGRAMS = \
+ p11-kit
+
+p11_kit_SOURCES = \
+ list.c \
+ p11-kit.c \
+ $(NULL)
+
+p11_kit_CFLAGS = \
+ $(NULL)
+
+p11_kit_LDADD = \
+ $(top_builddir)/p11-kit/libp11-kit.la \
+ $(top_builddir)/common/libp11-tool.la \
+ $(top_builddir)/common/libp11-common.la \
+ $(LTLIBINTL) \
+ $(NULL)