summaryrefslogtreecommitdiff
path: root/doc/manual/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@gnome.org>2012-08-23 15:34:04 +0200
committerStef Walter <stef@thewalter.net>2014-07-08 08:57:30 +0200
commitc785ab66890ad7b73c556d6afdf2bb8a32dd50e2 (patch)
treeb871dc6edf5e0a094fa3736eccdb92ca2a7091a8 /doc/manual/Makefile.am
parent469e75bb8184392cb47b3cb4897589caabe56e70 (diff)
rpc: Implement PKCS#11 messages/client/server code
* This enables passing around bytes which represent PKCS#11 RPC calls. * Caller is responsible for connecting/disconnecting and so on. * Client side caller gets a mixin from p11_rpc_client_init() to call into, which generates callbacks with byte arrays to be transported. * Server side calls p11_rpc_server_handle() with a CK_FUNCTION_LIST_PTR on which relevant methods get called. * Doesn't yet implement the actual daemon or clients etc... https://bugs.freedesktop.org/show_bug.cgi?id=54105
Diffstat (limited to 'doc/manual/Makefile.am')
-rw-r--r--doc/manual/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/doc/manual/Makefile.am b/doc/manual/Makefile.am
index c9ff264..dc15075 100644
--- a/doc/manual/Makefile.am
+++ b/doc/manual/Makefile.am
@@ -59,6 +59,8 @@ IGNORE_HFILES= \
pkcs11x.h \
private.h \
proxy.h \
+ rpc.h \
+ rpc-message.h \
util.h \
virtual.h \
array.h \