summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorStef Walter <stefw@collabora.co.uk>2011-03-03 15:50:56 +0100
committerStef Walter <stefw@collabora.co.uk>2011-03-03 15:50:56 +0100
commitd05a04968e07f6a2084ceb747938dc7cc049cb5f (patch)
treefbaba4e78b1a8b5c6145a37b1fd9ea739cb3a3ea /doc/Makefile.am
parent25cbc9b3293f2c6df38bd0528b89101e5e547321 (diff)
The start of some documentation.
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..52c269b
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,22 @@
+
+# p11-kit-glue.xml
+
+PARTS = \
+ p11-kit-config.xml \
+ p11-kit-multiple-problem.xml
+
+BOOK = \
+ p11-kit.xml
+
+DOCUMENTS = \
+ html/p11-kit.html
+
+all-local: $(DOCUMENTS)
+
+html/p11-kit.html: $(BOOK) $(PARTS)
+ xmlto --skip-validation -vv html-nochunks -o html/ p11-kit.xml
+
+EXTRA_DIST = \
+ $(BOOK) \
+ $(PARTS) \
+ docbook-params.xsl