summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-06-07 14:36:54 +0200
committerDaiki Ueno <ueno@gnu.org>2017-06-27 13:10:32 +0200
commitca9648c7c1cd38e306d7b3194900e4120eb179a0 (patch)
tree26079c0938eb51b8fa204f2ae0ce85cfc5533885 /configure.ac
parentf992eb64e8cd2925a37ec09d0f5dbd00b5fbb234 (diff)
configure: pull in -lnsl -lsocket for socket functions
Solaris has socket() etc. in these two libs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5753664..e812efe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,6 +88,13 @@ if test "$os_unix" = "yes"; then
AC_MSG_ERROR([could not find dlopen])
])
+ # for Solaris we need -lsocket -lnsl for socket stuff, gethostbyname
+ # is just a dummy to find -lnsl
+ AC_SEARCH_LIBS([gethostbyname], [nsl])
+ AC_SEARCH_LIBS([connect], [socket], [], [
+ AC_MSG_ERROR([could not find socket])
+ ])
+
# These are thngs we can work around
AC_CHECK_HEADERS([locale.h sys/resource.h])
AC_CHECK_MEMBERS([struct dirent.d_type],,,[#include <dirent.h>])