summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2017-05-26 14:47:35 +0200
committerDaiki Ueno <ueno@gnu.org>2017-05-26 17:45:17 +0200
commit80e3ce9eff5094c2c40905e2cb8b86c4aaf2329b (patch)
tree9270b303c2ddab8796e9f77a57e3dc6db519aa74 /configure.ac
parent4de8f7a9c4f8010069402ce943e5d777cd1f3c28 (diff)
test: Check the size of unsigned long
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 488b2ae..5382f6f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,8 @@ AC_C_BIGENDIAN
AC_HEADER_STDBOOL
+AC_CHECK_SIZEOF([unsigned long])
+
if test "$os_unix" = "yes"; then
AC_CHECK_FUNC([pthread_create], , [
AC_CHECK_LIB(pthread, pthread_create, , [