summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2018-04-27 09:51:59 +0200
committerDaiki Ueno <ueno@gnu.org>2018-05-01 13:30:43 +0200
commit6202903b261dfae740af3f8e985244bab48470ba (patch)
tree1a98dfeff05af569b7e1dd341da685dbf2e73a76 /configure.ac
parent173ad93cc54057886b2055f3d73ea64a047127d1 (diff)
Revert "build: Check strerror_l() and uselocale() seperately"
This reverts commit 173ad93cc54057886b2055f3d73ea64a047127d1. We should rather use newlocale() when per-thread locale is not set. Otherwise uselocale() could return LC_GLOBAL_LOCALE on some platforms (e.g. musl-libc) and calling strerror_l() with it leads to an undefined behavior.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 686bd06..7fcbe01 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,7 +101,7 @@ if test "$os_unix" = "yes"; then
AC_CHECK_MEMBERS([struct dirent.d_type],,,[#include <dirent.h>])
AC_CHECK_FUNCS([getprogname getexecname basename mkstemp mkdtemp])
AC_CHECK_FUNCS([getauxval issetugid getresuid secure_getenv])
- AC_CHECK_FUNCS([strnstr memdup strndup strerror_l strerror_r uselocale])
+ AC_CHECK_FUNCS([strnstr memdup strndup strerror_l strerror_r])
AC_CHECK_FUNCS([reallocarray])
AC_CHECK_FUNCS([fdwalk])
AC_CHECK_FUNCS([setenv])