summaryrefslogtreecommitdiff
path: root/common/meson.build
diff options
context:
space:
mode:
authorDaiki Ueno <dueno@redhat.com>2019-06-19 15:31:32 +0200
committerDaiki Ueno <ueno@gnu.org>2019-06-19 15:59:01 +0200
commiteb5eb7aea7fc41a2c15d853cd57c7c030644f4ee (patch)
tree53e4c60054375bd5197749edeaa02fec374602e1 /common/meson.build
parentdaf1a84de39c4cdbd308c6a0b80b437689a222c7 (diff)
build: Make threads dependency more explicit
Diffstat (limited to 'common/meson.build')
-rw-r--r--common/meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/common/meson.build b/common/meson.build
index 4614bcb..656592a 100644
--- a/common/meson.build
+++ b/common/meson.build
@@ -31,7 +31,8 @@ libp11_library = static_library('p11-library', 'library.c',
libp11_library_dep = declare_dependency(include_directories: [configinc,
commoninc],
- link_with: libp11_library)
+ link_with: libp11_library,
+ dependencies: thread_deps)
libp11_test_sources = [
'mock.c',
@@ -42,7 +43,8 @@ libp11_test = static_library('p11-test', libp11_test_sources,
include_directories: configinc)
libp11_test_dep = declare_dependency(include_directories: [configinc,
commoninc],
- link_with: libp11_test)
+ link_with: libp11_test,
+ dependencies: thread_deps)
libp11_tool_sources = [
'tool.c'