summaryrefslogtreecommitdiff
path: root/lib/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'lib/configure.ac')
-rw-r--r--lib/configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/lib/configure.ac b/lib/configure.ac
new file mode 100644
index 0000000..9f1972b
--- /dev/null
+++ b/lib/configure.ac
@@ -0,0 +1,35 @@
+# -*- Autoconf -*- script for libradsec.
+
+AC_PREREQ([2.65])
+AC_INIT([libradsec], [0.0.1], [linus+libradsec@nordu.net])
+AC_CONFIG_MACRO_DIR([m4])
+AM_INIT_AUTOMAKE
+AC_CONFIG_SRCDIR([radsec.c])
+AC_CONFIG_HEADERS([config.h])
+AC_PROG_LIBTOOL
+
+# Checks for programs.
+AC_PROG_CC
+
+# Checks for libraries.
+AC_CHECK_LIB([confuse], [cfg_init])
+AC_CHECK_LIB([event_core], [event_get_version])
+AC_CHECK_LIB([freeradius-radius], [rad_alloc])
+
+# Checks for header files.
+AC_CHECK_HEADERS([netdb.h netinet/in.h stdint.h stdlib.h string.h sys/socket.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_SIZE_T
+AC_TYPE_SSIZE_T
+AC_TYPE_UINT8_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([memset socket strdup strerror strrchr])
+
+AC_CONFIG_FILES([Makefile
+ include/Makefile
+ examples/Makefile])
+AC_OUTPUT